add another parallel build fix
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Oct 2006 19:31:45 +0000 (19:31 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Oct 2006 19:31:45 +0000 (19:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5209 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic-2.4/patches/051-parallel_build.patch [new file with mode: 0644]

diff --git a/target/linux/generic-2.4/patches/051-parallel_build.patch b/target/linux/generic-2.4/patches/051-parallel_build.patch
new file mode 100644 (file)
index 0000000..2ea70df
--- /dev/null
@@ -0,0 +1,21 @@
+--- linux-2.4.32/arch/mips/Makefile.old        2006-10-18 21:11:18.110720000 +0200
++++ linux-2.4.32/arch/mips/Makefile    2006-10-18 21:12:32.570720000 +0200
+@@ -752,6 +752,7 @@
+ HEAD := arch/mips/kernel/head.o arch/mips/kernel/init_task.o
+ SUBDIRS := $(addprefix arch/mips/, tools) $(SUBDIRS) $(addprefix arch/mips/, kernel mm lib)
++$(SUBDIRS): $(TOPDIR)/include/asm-$(ARCH)/offset.h
+ CORE_FILES := arch/mips/kernel/kernel.o arch/mips/mm/mm.o $(CORE_FILES)
+ LIBS := arch/mips/lib/lib.a $(LIBS)
+@@ -799,7 +800,7 @@
+       $(MAKE) -C arch/$(ARCH)/tools mrproper
+ archdep:
+-      if [ ! -f $(TOPDIR)/include/asm-$(ARCH)/offset.h ]; then \
+-              touch $(TOPDIR)/include/asm-$(ARCH)/offset.h; \
+-      fi;
+       @$(MAKEBOOT) dep
++
++$(TOPDIR)/include/asm-$(ARCH)/offset.h:
++      @$(MAKE) -C arch/mips/tools