make IGNORE_ERRORS apply to deselected packages as well (backport from r23796)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 2 Nov 2010 16:40:06 +0000 (16:40 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 2 Nov 2010 16:40:06 +0000 (16:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@23797 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile

index 5468bdc71879df5c378a635e677695810a7f46a4..786edd49f00955ea114e80caad8347847a9b0f31 100644 (file)
@@ -17,7 +17,7 @@ else
   $(curdir)/builddirs-install:=. $(sort $(package-y))
 endif
 ifneq ($(IGNORE_ERRORS),)
-  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+  $(curdir)/builddirs-ignore-compile:= $(if $(filter n m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(subst n,,$(m)))),$(package-m) $(package-))
 endif
 
 $(curdir)/install:=$(curdir)/install-cleanup