minor makefile tweaks
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Aug 2006 12:07:14 +0000 (12:07 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Aug 2006 12:07:14 +0000 (12:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4393 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/package.mk
rules.mk

index 85091f618e8fb0d5d0b0b54025a436e8ceadcaa6..a520ffde2d6bb3c54f0e7ba00221ae92a1ac2949 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,18 +14,17 @@ RELEASE:=Kamikaze
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  ifneq ($(REV),)
+    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+  endif
 endif
 export OPENWRTVERSION
 
@@ -40,7 +39,7 @@ endif
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || echo "ERROR: please fix package/$${dir}/Makefile" >&2; \
        done > $@
 
 .config.in: .pkginfo
@@ -129,5 +128,6 @@ distclean: dirclean config-clean
 
 
 .SILENT: clean dirclean distclean config-clean download world
+FORCE: ;
 .PHONY: FORCE
-FORCE:
+%: ;
index cd1a33c484874a8f271dea4a9f356bf706ce68b3..3dc944dbfa0a21774866fd1e0027c91f5ae7d18f 100644 (file)
@@ -40,19 +40,19 @@ define Build/DefaultTargets
        $(call Build/Compile)
        touch $$@
 
-  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
+  ifdef Build/InstallDev
+    $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/stampfiles
        $(call Build/InstallDev)
        touch $$@
        
-  ifdef Build/InstallDev
     compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
   endif
 
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
-       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+       -rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
        @-rm -f $(PKG_BUILD_DIR)/.built
@@ -89,9 +89,9 @@ define Package/Default
 endef
 
 define BuildIPKGVariable
-pkg_$(subst .,_,$(subst -,_,$(1)))_$(2) = $$(Package/$(1)/$(2))
-export pkg_$(subst .,_,$(subst -,_,$(1))_$(2))
-$(1)_COMMANDS += if [ -n "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" ]; then echo "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" > $(2); fi;
+  pkg_$(subst .,_,$(subst -,_,$(1)))_$(2) = $$(Package/$(1)/$(2))
+  export pkg_$(subst .,_,$(subst -,_,$(1))_$(2))
+  $(1)_COMMANDS += if [ -n "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" ]; then echo "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" > $(2); fi;
 endef
 
 define BuildPackage
@@ -132,29 +132,30 @@ define BuildPackage
 
   IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
-  DUMPINFO += \
+  ifneq ($(DUMP),)
+    DUMPINFO += \
        echo "Package: $(1)"; 
 
-  ifneq ($(MENU),)
-    DUMPINFO += \
+    ifneq ($(MENU),)
+      DUMPINFO += \
        echo "Menu: $(MENU)";
-  endif
+    endif
 
-  ifneq ($(SUBMENU),)
-    DUMPINFO += \
-       echo "Submenu: $(SUBMENU)";
-    ifneq ($(SUBMENUDEP),)
+    ifneq ($(SUBMENU),)
       DUMPINFO += \
+       echo "Submenu: $(SUBMENU)";
+      ifneq ($(SUBMENUDEP),)
+        DUMPINFO += \
          echo "Submenu-Depends: $(SUBMENUDEP)";
+      endif
     endif
-  endif
 
-  ifneq ($(DEFAULT),)
-    DUMPINFO += \
+    ifneq ($(DEFAULT),)
+      DUMPINFO += \
        echo "Default: $(DEFAULT)";
-  endif
+    endif
 
-  DUMPINFO += \
+    DUMPINFO += \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
        echo "Build-Depends: $(PKG_BUILDDEP)"; \
@@ -162,19 +163,20 @@ define BuildPackage
        echo "Title: $(TITLE)"; \
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
 
-  ifneq ($(URL),)
-    DUMPINFO += \
+    ifneq ($(URL),)
+      DUMPINFO += \
        echo; \
        echo "$(URL)";
-  endif
+    endif
 
-  DUMPINFO += \
+    DUMPINFO += \
        echo "@@";
 
-  ifneq ($(CONFIG),)
-    DUMPINFO += \
+    ifneq ($(CONFIG),)
+      DUMPINFO += \
        echo "Config: $(CONFIG)" | sed -e 's,\\,\n,g'; \
        echo "@@";
+    endif
   endif
 
   $(eval $(call BuildIPKGVariable,$(1),conffiles))
@@ -182,7 +184,7 @@ define BuildPackage
   $(eval $(call BuildIPKGVariable,$(1),postinst))
   $(eval $(call BuildIPKGVariable,$(1),prerm))
   $(eval $(call BuildIPKGVariable,$(1),postrm))
-  $$(IDIR_$(1))/CONTROL/control: Makefile $(PKG_BUILD_DIR)/.prepared $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
+  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -204,7 +206,7 @@ define BuildPackage
                $($(1)_COMMANDS) \
        )
 
-  $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
+  $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
        -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
@@ -227,7 +229,6 @@ define BuildPackage
        @touch $$@
 
   $$(eval $$(call Build/DefaultTargets,$(1)))
-
 endef
 
 ifneq ($(strip $(PKG_CAT)),)
index 33e8354b8c85e6d9d05aac8c61e58130a2aea2f1..206e57dd03e1f6cd2a461ccf1194307166328481 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -117,3 +117,4 @@ endif
 all:
 FORCE: ;
 .PHONY: FORCE
+%: ;