use qstrip macro to strip quoted CONFIG_* strings
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Jul 2008 23:24:58 +0000 (23:24 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Jul 2008 23:24:58 +0000 (23:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11832 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/binutils/Makefile
toolchain/gcc/Makefile
toolchain/uClibc/Makefile

index 8682fa5969ddb025067f10f068cad181a9f8158c..1023d9e671b6d0bba7000ae668c4a427f0ce2cb0 100644 (file)
@@ -7,8 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=binutils
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
-#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
 
 PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
        ftp://gatekeeper.dec.com/pub/GNU/ \
index ef5ab22d0f62cc1341941cb6b4d11a694ccc384a..31697989c9309044d5ae81196e5877948054c201 100644 (file)
@@ -21,7 +21,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gcc
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
 
 PATCH_DIR=./patches/$(PKG_VERSION)
 PKG_SOURCE_URL:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(PKG_VERSION) \
index e6f2b7b1915447ffb1df2a15e3d4318a3f5c9c28..8c02489b1431d168a5519614ac61d9042d84435c 100644 (file)
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=uClibc
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION)))#"))
-PKG_EXTRAVERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_EXTRA_VERSION)))#"))
-PKG_VERSION_SNAPSHOT:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION_SNAPSHOT)))#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_UCLIBC_VERSION))
+PKG_EXTRAVERSION:=$(call qstrip,$(CONFIG_UCLIBC_EXTRA_VERSION))
+PKG_VERSION_SNAPSHOT:=$(call qstrip,$(CONFIG_UCLIBC_VERSION_SNAPSHOT))
 ifeq ($(PKG_VERSION_SNAPSHOT),y)
 PKG_SOURCE_URL:=http://www.uclibc.org/downloads/snapshots
 else