fix toolchain build, remove some old gcc junk
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 May 2006 16:53:36 +0000 (16:53 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 May 2006 16:53:36 +0000 (16:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3839 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk
toolchain/gcc/Makefile

index 0e7dd2e044ca6bcba4360f53f6230d24a1e1cfdb..a613beaf40be3daa40e95b726597b79d1e3fa555 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -29,28 +29,9 @@ MAKEFLAGS=-j$(CONFIG_JLEVEL) V=$(V) $(EXTRA_MAKEFLAGS)
 # Strip off the annoying quoting
 ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
 WGET:=$(strip $(subst ",, $(CONFIG_WGET)))
-GCC_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))
-GCC_USE_SJLJ_EXCEPTIONS:=$(strip $(subst ",, $(CONFIG_GCC_USE_SJLJ_EXCEPTIONS)))
 TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
 #"))"))"))"))")) # for vim's broken syntax highlighting :)
 
-
-ifeq ($(CONFIG_SOFT_FLOAT),y)
-# gcc 3.4.x soft float configuration is different than previous versions.
-ifeq ($(findstring 3.4.,$(GCC_VERSION)),3.4.)
-SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
-else
-SOFT_FLOAT_CONFIG_OPTION:=--without-float
-endif
-TARGET_SOFT_FLOAT:=-msoft-float
-ARCH_FPU_SUFFIX:=_nofpu
-else
-SOFT_FLOAT_CONFIG_OPTION:=
-TARGET_SOFT_FLOAT:=
-ARCH_FPU_SUFFIX:=
-endif
-
-
 ifeq ($(CONFIG_TAR_VERBOSITY),y)
 TAR_OPTIONS=-xvf
 else
@@ -66,17 +47,17 @@ OPTIMIZE_FOR_CPU=$(ARCH)
 HOSTCC:=gcc
 BASE_DIR:=$(TOPDIR)
 DL_DIR:=$(BASE_DIR)/dl
-BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
-STAGING_DIR:=$(BASE_DIR)/staging_dir_$(ARCH)$(ARCH_FPU_SUFFIX)
+BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)
+STAGING_DIR:=$(BASE_DIR)/staging_dir_$(ARCH)
 SCRIPT_DIR:=$(BASE_DIR)/scripts
 BIN_DIR:=$(BASE_DIR)/bin
 STAMP_DIR:=$(BUILD_DIR)/stamp
 PACKAGE_DIR:=$(BIN_DIR)/packages
 STAMP_DIR:=$(BUILD_DIR)/stamp
 TARGET_DIR:=$(BUILD_DIR)/root
-TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
+TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)
 TARGET_PATH=$(STAGING_DIR)/usr/bin:$(STAGING_DIR)/bin:/bin:/sbin:/usr/bin:/usr/sbin
-IMAGE:=$(BUILD_DIR)/root_fs_$(ARCH)$(ARCH_FPU_SUFFIX)
+IMAGE:=$(BUILD_DIR)/root_fs_$(ARCH)
 REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux-uclibc
 GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
 KERNEL_CROSS:=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
index 7c037edddc0673b4458e902c82bf500b74019c22..1ce00101b5bff20640f01bbd6326fa79aed0b55c 100644 (file)
@@ -20,7 +20,7 @@
 
 include $(TOPDIR)/rules.mk
 
-GCC_VERSION:=$(strip $(CONFIG_GCC_VERSION))
+GCC_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))#"))
 
 #GCC_SITE:=ftp://ftp.gnu.org/gnu/gcc/releases/gcc-$(GCC_VERSION)
 GCC_SITE:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(GCC_VERSION) \
@@ -29,7 +29,6 @@ GCC_SITE:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(GCC_VERSION)
 GCC_SOURCE:=gcc-$(GCC_VERSION).tar.bz2
 GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-$(GCC_VERSION)
 GCC_CAT:=bzcat
-GCC_STRIP_HOST_BINARIES:=true
 
 #############################################################
 #
@@ -71,14 +70,6 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
        # We can dispense with the custom spec files, as well as libfloat for the arm case.
        # However, we still need a patch for arm.  There's a similar patch for gcc 3.3.x
        # which needs to be integrated so we can kill of libfloat for good.
-ifeq ($(CONFIG_SOFT_FLOAT),y)
-ifeq ("$(strip $(ARCH))","arm")
-       $(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
-endif
-ifeq ("$(strip $(ARCH))","armeb")
-       $(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
-endif
-endif
        $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(GCC_DIR)/gcc/version.c
        $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(GCC_DIR)/gcc/version.c
        touch $(GCC_DIR)/.patched
@@ -103,9 +94,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
                --with-gnu-ld \
                $(DISABLE_NLS) \
                $(MULTILIB) \
-               $(SOFT_FLOAT_CONFIG_OPTION) \
-               $(GCC_WITH_CPU) $(GCC_WITH_ARCH) $(GCC_WITH_TUNE) \
-               $(EXTRA_GCC_CONFIG_OPTIONS));
+       );
        touch $(GCC_BUILD_DIR1)/.configured
 
 $(GCC_BUILD_DIR1)/.compiled: $(GCC_BUILD_DIR1)/.configured
@@ -149,10 +138,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(STAGING_DIR)/lib/libc.a
                --with-gnu-ld \
                $(DISABLE_NLS) \
                $(MULTILIB) \
-               $(SOFT_FLOAT_CONFIG_OPTION) \
-               $(GCC_WITH_CPU) $(GCC_WITH_ARCH) $(GCC_WITH_TUNE) \
-               $(GCC_USE_SJLJ_EXCEPTIONS) \
-               $(EXTRA_GCC_CONFIG_OPTIONS));
+       );
        touch $(GCC_BUILD_DIR2)/.configured
 
 $(GCC_BUILD_DIR2)/.compiled: $(GCC_BUILD_DIR2)/.configured
@@ -172,24 +158,6 @@ gcc-install: $(GCC_BUILD_DIR2)/.compiled
                        $(GNU_TARGET_NAME)$${app##$(REAL_GNU_TARGET_NAME)}; \
                done; \
        );
-       #
-       # Now for the ugly 3.3.x soft float hack...
-       #
-ifeq ($(CONFIG_SOFT_FLOAT),y)
-ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
-       # Make sure we have a soft float specs file for this arch
-       if [ ! -f ./$(GCC_VERSION)/specs-$(ARCH)-soft-float ] ; then \
-               echo soft float configured but no specs file for this arch ; \
-               /bin/false ; \
-       fi;
-       # Replace specs file with one that defaults to soft float mode.
-       if [ ! -f $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
-               echo staging dir specs file is missing ; \
-               /bin/false ; \
-       fi;
-       $(CP) ./$(GCC_VERSION)/specs-$(ARCH)-soft-float $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
-endif
-endif
 # We do another ugly hack here because the standard behaviour is
 # to include a reference to libgcc.so.1 in all binaries. For flash space
 # saving, we change the specs file to link in a static libgcc here.