[backfire] merge r22552
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Aug 2010 04:44:38 +0000 (04:44 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Aug 2010 04:44:38 +0000 (04:44 +0000)
[tools] qemu: build qemu-img for packaging vmdk and vdi images

git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@22555 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/qemu/Makefile [new file with mode: 0644]

index 808ea84129472dbc9c128e832d18812f863a622c..94f7ce699aa99cb94f43b609e0295b814d7b710f 100644 (file)
@@ -17,6 +17,7 @@ tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
+tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
 tools-y += squashfs lzma-old
 else
@@ -43,6 +44,7 @@ $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
 $(curdir)/mtd-utils/compile := $(curdir)/libuuid/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
+$(curdir)/upslug2/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
diff --git a/tools/qemu/Makefile b/tools/qemu/Makefile
new file mode 100644 (file)
index 0000000..7d4eb0b
--- /dev/null
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=qemu
+PKG_VERSION:=0.12.5
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/qemu/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=1d02ee0a04dfae2894340273372c1de4
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); \
+               CFLAGS="$(HOST_CFLAGS)" \
+               LDFLAGS="$(HOST_LDFLAGS)" \
+               $(HOST_CONFIGURE_CMD) \
+               --extra-cflags="$(HOST_CFLAGS)" \
+               --enable-uuid \
+       )
+endef
+
+define Host/Compile
+       (cd $(HOST_BUILD_DIR); \
+               make qemu-img \
+       )
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/qemu-img $(STAGING_DIR_HOST)/bin
+endef
+
+$(eval $(call HostBuild))