fix mtd-utils compile on freebsd
[openwrt-10.03/.git] / tools / mtd-utils / Makefile
index 55dd88a785101171b84be0b0e4ea7a9d37972e35..f67ccf758fb4fc2bd8e0b483d4fb00d8ad15b10f 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 CFLAGS := $(HOSTCFLAGS) -O2 -I../include
 ifneq ($(OS),Linux)
-CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h
+CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h -include endian.h
 endif
 
 define Build/Compile