[tools] firmware-utils: copy bcm_tag.h to src/ and get rid of cc3 macro, fixes imaget...
[openwrt-10.03/.git] / tools / firmware-utils / Makefile
index 85ef59509ea33a2d9555f804c3e12c584d494569..c5fbb70cbcfb79cd27055d9f31715c30ae7e3a75 100644 (file)
@@ -20,10 +20,6 @@ define cc2
        $(CC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
-define cc3
-       $(CC) $(HOST_CFLAGS) -I$(CURDIR)/../../target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx -include endian.h -o $(HOST_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
-endef
-
 
 define Host/Compile
        mkdir -p $(HOST_BUILD_DIR)/bin
@@ -42,7 +38,7 @@ define Host/Compile
        $(call cc,mkcasfw)
        $(call cc,mkfwimage,-lz)
        $(call cc,mkfwimage2,-lz)
-       $(call cc3,imagetag)
+       $(call cc2,imagetag)
        $(call cc,add_header)
        $(call cc,makeamitbin)
        $(call cc,encode_crc)