bcm963xx: add cfe image tagging utility
[openwrt-10.03/.git] / tools / firmware-utils / Makefile
index 6a0c223c580637c30739e4d79cb66d6ac4d730f8..acb429c4438ff06bf1c708e4addb010fa50384c2 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -28,10 +28,13 @@ define Build/Compile
        $(call cc,mkcsysimg)
        $(call cc,mkzynfw)
        $(call cc,lzma2eva,-lz)
+       $(call cc,mkcasfw)
+       $(call cc,mkfwimage,-lz)
+       $(call cc,imagetag)
 endef
 
 define Build/Install
-       $(CP) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR_HOST)/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR_HOST)/bin/
 endef
 
 $(eval $(call HostBuild))