ar7: add eva image generation (thanks Axel Gembe)
[openwrt-10.03/.git] / tools / firmware-utils / Makefile
index f458693564915248e2001ceb1b1893f234347359..6a0c223c580637c30739e4d79cb66d6ac4d730f8 100644 (file)
@@ -11,7 +11,7 @@ PKG_NAME := firmware-utils
 include $(INCLUDE_DIR)/host-build.mk
 
 define cc
-       $(CC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c
+       $(CC) $(HOST_CFLAGS) -include endian.h -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c $(2)
 endef
 
 define Build/Compile
@@ -27,6 +27,7 @@ define Build/Compile
        $(call cc,mkmylofw)
        $(call cc,mkcsysimg)
        $(call cc,mkzynfw)
+       $(call cc,lzma2eva,-lz)
 endef
 
 define Build/Install