build system fixes, more cleanup
[openwrt-10.03/.git] / tools / Makefile
index c8fad2323683df3d62275ea3981b38fbebe41e08..ed2eae89d93006c59c49f395b875d689e7b0fa67 100644 (file)
@@ -1,60 +1,31 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the host tools
 #
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
+curdir:=tools
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
-clean: $(TARGETS_CLEAN)
+# subdirectories to descend into
+tools/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
 
-squashfs-compile: lzma-install
+# builddir dependencies
+tools/squashfs/compile := tools/lzma/install
 
-TOOL_STAMP_DIR:=$(STAGING_DIR)/stampfiles
+# preparatory work
+$(STAGING_DIR)/include-host/.done:
+       @mkdir -p $$(dirname $@)
+       @cp tools/include/*.h $$(dirname $@)/
+       @touch $@
 
-$(TOOL_STAMP_DIR):
-       mkdir -p $@
-
-$(STAGING_DIR)/include-host:
-       @mkdir -p $@
-       @$(CP) ./include/*.h $@/
-
-$(TOOL_BUILD_DIR):
-       @mkdir -p $@
-
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(TOOL_STAMP_DIR) $(STAGING_DIR)/include-host $(TOOL_BUILD_DIR) FORCE
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-compile: %-prepare 
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-install: %-compile
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-install,%,$@) install; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-clean: FORCE
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(TOOL_STAMP_DIR)/.tool_$(patsubst %-clean,%,$@)-*
+# prerequisites for the individual targets
+tools/ := .config
+tools//prepare = $(STAGING_DIR)/include-host/.done
+tools//compile = $(1)/prepare
+tools//install = $(1)/compile
 
+$(eval $(call stampfile,tools,tools))
+$(eval $(call subdir,tools))