build system fixes, more cleanup
[openwrt-10.03/.git] / tools / Makefile
index 265c6aebf5c997b154eaf86e25656e21ad07223f..ed2eae89d93006c59c49f395b875d689e7b0fa67 100644 (file)
@@ -1,60 +1,31 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the host tools
 #
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
-TARGETS-$(CONFIG_CCACHE) += ccache
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.tools_installed
+curdir:=tools
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP)
-clean: $(TARGETS_CLEAN)
+# subdirectories to descend into
+tools/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
 
-squashfs-compile: lzma-install
+# builddir dependencies
+tools/squashfs/compile := tools/lzma/install
 
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
-  $(STAMP): $(TARGETS_INSTALL)
-endif
+# preparatory work
+$(STAGING_DIR)/include-host/.done:
+       @mkdir -p $$(dirname $@)
+       @cp tools/include/*.h $$(dirname $@)/
+       @touch $@
 
-$(STAMP): $(TOPDIR)/.config
-       mkdir -p $(shell dirname $@)
-       touch $@
+# prerequisites for the individual targets
+tools/ := .config
+tools//prepare = $(STAGING_DIR)/include-host/.done
+tools//compile = $(1)/prepare
+tools//install = $(1)/compile
 
-TOOL_HOST_INCLUDES:=$(patsubst ./include/%.h,$(STAGING_DIR)/include-host/%.h,$(wildcard ./include/*.h))
-$(TOOL_HOST_INCLUDES): $(STAGING_DIR)/include-host/%.h: ./include/%.h
-       @mkdir -p $(STAGING_DIR)/include-host
-       $(CP) $< $@
-
-$(TOOL_BUILD_DIR):
-       @mkdir -p $@
-
-%-prereq %-download %-clean %-refresh: FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-prepare: $(TOOL_HOST_INCLUDES) $(TOOL_BUILD_DIR) FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-compile: %-prepare FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-       
-%-install: %-compile FORCE
-       $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-ifeq ($(MAKECMDGOALS),install-targets)
-MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
-else
-.NOTPARALLEL:
-endif
+$(eval $(call stampfile,tools,tools))
+$(eval $(call subdir,tools))