make the lzma version kernel version dependent, and only build the one we do need
[openwrt-10.03/.git] / tools / Makefile
index b7c7f43db6f98ce253d6430684587ffe72d618de..e3e26f3c4ff04eb4fe7a04bb49ff9054f43246ed 100644 (file)
@@ -14,11 +14,15 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
-tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
+tools-y += sstrip ipkg-utils genext2fs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_28),)
+tools-y += squashfs lzma-old 
+else
+tools-y += squashfs4 lzma
+endif
 
 tools-$(CONFIG_CCACHE) += ccache
-tools-dep += lzma
 
 ifdef CONFIG_GCC_USE_GRAPHITE
   tools-y += ppl cloog