gcc: add a config option for using the gcc graphite framework (disabled by default)
[openwrt-10.03/.git] / tools / Makefile
index 6e5eb24cd3dce632a4c1e5db6d9eec349a3fe56e..b7c7f43db6f98ce253d6430684587ffe72d618de 100644 (file)
@@ -20,7 +20,7 @@ tools-y += firmware-utils patch-cmdline quilt yaffs2
 tools-$(CONFIG_CCACHE) += ccache
 tools-dep += lzma
 
-ifdef CONFIG_GCC_VERSION_4_4
+ifdef CONFIG_GCC_USE_GRAPHITE
   tools-y += ppl cloog
   $(curdir)/cloog/compile := $(curdir)/ppl/install
 endif
@@ -82,5 +82,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE))
 $(eval $(call subdir,$(curdir)))