install a symlink to the correct version of find in $(STAGING_DIR_HOST)/bin
[openwrt-10.03/.git] / tools / Makefile
index 3cfbb8bbda19f2bddec37dc249783d110781b23d..989f3f09759dbb123af5189f3f941c93583d386c 100644 (file)
@@ -26,8 +26,11 @@ $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        touch $@
 
-$(curdir)//prepare = $(STAGING_DIR)/.prepared
-$(curdir)//compile = $(STAGING_DIR)/.prepared
+$(STAGING_DIR_HOST)/bin/find:
+       [ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
+
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/bin/find
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq