[backfire] backport r27648
[openwrt-10.03/.git] / tools / Makefile
index 3f16ce5e5120e73caa8fa4abe39e78769c956718..8cb50648df1191a15c5ae134a7efd64605446cb1 100644 (file)
@@ -13,10 +13,10 @@ tools-y :=
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
-tools-y += m4 libtool autoconf automake bison pkg-config sed mklibs
+tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 xz cmake
-tools-y += mm-macros xorg-macros missing-macros
+tools-y += mm-macros xorg-macros xfce-macros missing-macros
 tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
@@ -35,6 +35,7 @@ ifdef CONFIG_GCC_USE_GRAPHITE
 endif
 
 # builddir dependencies
+$(curdir)/bison/compile := $(curdir)/flex/install
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
 $(curdir)/libtool/compile := $(curdir)/sed/install
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install
@@ -50,6 +51,7 @@ $(curdir)/qemu/compile := $(curdir)/libuuid/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
 $(curdir)/mm-macros/compile := $(curdir)/automake/install
 $(curdir)/xorg-macros/compile := $(curdir)/automake/install
+$(curdir)/xfce-macros/compile := $(curdir)/automake/install
 $(curdir)/missing-macros/compile := $(curdir)/automake/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)