initial attempt at cleaning up subdirectory handling. tools/Makefile is now being...
[openwrt-10.03/.git] / tools / Makefile
index d03ab38ee38343a86f6c61dc4451a5c8874ffa8e..0d6b51597732d3a81d9688c2c702fb614a85a67c 100644 (file)
@@ -1,48 +1,28 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the host tools
 #
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.tools_installed
+curdir:=$(patsubst %/Makefile,%,$(lastword $(MAKEFILE_LIST)))
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP)
-clean: $(TARGETS_CLEAN)
+# subdirectories to descend into
+$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
 
-squashfs-compile: lzma-install
+# builddir dependencies
+$(curdir)/squashfs/compile := $(curdir)/lzma/install
 
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
-  $(STAMP): $(TARGETS_INSTALL)
-endif
+# preparatory work
+$(STAGING_DIR)/include-host/.done:
+       @mkdir -p $$(dirname $@)
+       @cp $(curdir)/include/*.h $$(dirname $@)/
+       @touch $@
 
-$(STAMP):
-       mkdir -p $(shell dirname $@)
-       touch $@
-       
-$(STAGING_DIR)/include-host:
-       @mkdir -p $@
-       @$(CP) ./include/*.h $@/
-
-$(TOOL_BUILD_DIR):
-       @mkdir -p $@
-
-$(eval $(call default_subtargets,$(STAGING_DIR)/include-host $(TOOL_BUILD_DIR)))
-
-ifeq ($(MAKECMDGOALS),install-targets)
-MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
-else
-.NOTPARALLEL:
-endif
+# prerequisites for the individual targets
+$(curdir)/ := .config
+$(curdir)//prepare := $(STAGING_DIR)/include-host/.done
+$(eval $(call stampfile,$(curdir),tools))
+$(eval $(call subdir,$(curdir)))