initial attempt at cleaning up subdirectory handling. tools/Makefile is now being...
[openwrt-10.03/.git] / tools / Makefile
index c8fad2323683df3d62275ea3981b38fbebe41e08..0d6b51597732d3a81d9688c2c702fb614a85a67c 100644 (file)
@@ -1,60 +1,28 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the host tools
 #
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
+curdir:=$(patsubst %/Makefile,%,$(lastword $(MAKEFILE_LIST)))
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
-clean: $(TARGETS_CLEAN)
+# subdirectories to descend into
+$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
 
-squashfs-compile: lzma-install
+# builddir dependencies
+$(curdir)/squashfs/compile := $(curdir)/lzma/install
 
-TOOL_STAMP_DIR:=$(STAGING_DIR)/stampfiles
-
-$(TOOL_STAMP_DIR):
-       mkdir -p $@
-
-$(STAGING_DIR)/include-host:
-       @mkdir -p $@
-       @$(CP) ./include/*.h $@/
-
-$(TOOL_BUILD_DIR):
-       @mkdir -p $@
-
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(TOOL_STAMP_DIR) $(STAGING_DIR)/include-host $(TOOL_BUILD_DIR) FORCE
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-compile: %-prepare 
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-install: %-compile
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-install,%,$@) install; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-clean: FORCE
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(TOOL_STAMP_DIR)/.tool_$(patsubst %-clean,%,$@)-*
+# preparatory work
+$(STAGING_DIR)/include-host/.done:
+       @mkdir -p $$(dirname $@)
+       @cp $(curdir)/include/*.h $$(dirname $@)/
+       @touch $@
 
+# prerequisites for the individual targets
+$(curdir)/ := .config
+$(curdir)//prepare := $(STAGING_DIR)/include-host/.done
+$(eval $(call stampfile,$(curdir),tools))
+$(eval $(call subdir,$(curdir)))