[toolchain/uclibc]: upgrade and fixup support for the uclibc nptl branch
[openwrt-10.03/.git] / toolchain / uClibc / patches-0.9.30+nptl / 150-use_gnu99.patch
diff --git a/toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch b/toolchain/uClibc/patches-0.9.30+nptl/150-use_gnu99.patch
new file mode 100644 (file)
index 0000000..bfa5558
--- /dev/null
@@ -0,0 +1,33 @@
+--- a/libpthread/nptl/Makefile.in
++++ b/libpthread/nptl/Makefile.in
+@@ -174,7 +174,7 @@
+ CFLAGS-pthread_barrierattr_setpshared.c = -D_GNU_SOURCE
+ CFLAGS-sem_open.c = -D_GNU_SOURCE
+-CFLAGS-nptl = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 $(SSP_ALL_CFLAGS)
++CFLAGS-nptl = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 -std=gnu99 $(SSP_ALL_CFLAGS)
+ CFLAGS-OMIT-alloca_cutoff.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
+ CFLAGS-OMIT-forward.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/Makefile.in
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/Makefile.in
+@@ -82,7 +82,7 @@
+ CFLAGS-timer_routines.c = -I$(top_srcdir)librt -DIS_IN_librt=1
+ CFLAGS-timer_settime.c = -I$(top_srcdir)librt -DIS_IN_librt=1
+-CFLAGS-linux = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 $(SSP_ALL_CFLAGS)
++CFLAGS-linux = -DNOT_IN_libc=1 -DIS_IN_libpthread=1 -std=gnu99 $(SSP_ALL_CFLAGS)
+ #CFLAGS:=$(CFLAGS:-O1=-O2)
+ CFLAGS-OMIT-libc_pthread_init.c = -DNOT_IN_libc=1 -DIS_IN_libpthread=1
+--- a/ldso/ldso/Makefile.in
++++ b/ldso/ldso/Makefile.in
+@@ -13,7 +13,7 @@
+ CFLAGS-ldso += -fno-omit-frame-pointer
+ CFLAGS-ldso += -I$(top_srcdir)ldso/ldso/$(TARGET_ARCH) -I$(top_srcdir)ldso/include -I$(top_srcdir)ldso/ldso
+-CFLAGS-ldso += -DUCLIBC_RUNTIME_PREFIX=\"$(RUNTIME_PREFIX)\" -DUCLIBC_LDSO=\"$(UCLIBC_LDSO)\"
++CFLAGS-ldso += -DUCLIBC_RUNTIME_PREFIX=\"$(RUNTIME_PREFIX)\" -DUCLIBC_LDSO=\"$(UCLIBC_LDSO)\" -std=gnu99
+ ifeq ($(DODEBUG),y)
+ # Not really much point in including debugging info, since gdb