uclibc: to rebuild libc.so.0, mklibs.py needs access to libc_so.a which was not expor...
[openwrt-10.03/.git] / toolchain / uClibc / Makefile
index 1b8723f6781335b357aab1f00de6e97d837e00bf..7206df27200c0ae2d1954397ed29a6f4d28a7f17 100644 (file)
@@ -102,6 +102,7 @@ define Host/Compile
        $(UCLIBC_MAKE) PREFIX= all
        $(UCLIBC_MAKE) PREFIX="$(TOOLCHAIN_DIR)/" install_runtime install_dev
        ln -sf ../../lib/libc.so.0 $(TOOLCHAIN_DIR)/usr/lib/libc.so
+       $(CP) $(HOST_BUILD_DIR)/libc/libc_so.a $(TOOLCHAIN_DIR)/usr/lib/
 #      ( cd $(TOOLCHAIN_DIR) ; \
 #              for d in lib usr/lib ; do \
 #                for f in libc.so libpthread.so libgcc_s.so ; do \