fix problems with new tar versions, closes #628 and #646
[openwrt-10.03/.git] / toolchain / kernel-headers / Makefile
index 7e08508b636e8bf9c577e781901708d539b7ba75..da525d5f3763eb13b95906f974a41ab3d8c7cac0 100644 (file)
@@ -31,7 +31,7 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
 
 define Build/Prepare
        mkdir -p $(TOOL_BUILD_DIR)
-       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) - \
+       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar --wildcards -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) - \
                linux-$(PKG_VERSION)/include \
                linux-$(PKG_VERSION)/Makefile \
                linux-$(PKG_VERSION)/Rules.make \