[toolchain] move common variables to a dedicated include file
[openwrt-10.03/.git] / toolchain / glibc-ports / Makefile
index 2ddeb4e2be23983ff468cdedc72022749156c7bc..836ca3466de21a4cd22ecb6fc1351fc9b78f5183 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,37 +21,31 @@ endif
 
 PKG_SOURCE_URL:=@GNU/glibc/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
 
 PATCH_DIR:=./patches/$(PKG_VERSION)
 
-STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
-BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
-
-override CONFIG_AUTOREBUILD=
-
-include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/toolchain-build.mk
 
 STAMP_BUILT:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_built
 STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_installed
 
-define Build/Prepare
-$(call Build/Prepare/Default)
+define Host/Prepare
+$(call Host/Prepare/Default)
        ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
 endef
 
-define Build/Configure
+define Host/Configure
 endef
 
-define Build/Compile
+define Host/Compile
 endef
 
-define Build/Install
+define Host/Install
 endef
 
-define Build/Clean
+define Host/Clean
        rm -rf \
-               $(PKG_BUILD_DIR) \
+               $(HOST_BUILD_DIR) \
                $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
 endef