[backfire] backport r27648
[openwrt-10.03/.git] / toolchain / gdb / Makefile
index 63661ca2dcc0b9de2232e9be9772b02c6e23f0e2..df4fe55a4a86091716cede3e93febb65f1d138d5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,42 +7,48 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=6.3
+PKG_VERSION:=6.8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=05b928f41fa5b482e49ca2c24762a0ae
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/gdb
-PKG_CAT:=bzcat
+PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
+PKG_SOURCE_URL:=@GNU/gdb
 
-PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+include $(INCLUDE_DIR)/toolchain-build.mk
 
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); \
                gdb_cv_func_sigsetjmp=yes \
-               $(PKG_BUILD_DIR)/configure \
-               --prefix=$(STAGING_DIR) \
+               CFLAGS="-O2" \
+               $(HOST_BUILD_DIR)/configure \
+               --prefix=$(TOOLCHAIN_DIR)/usr \
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
+               --disable-werror \
                $(DISABLE_NLS) \
-               --without-uiout --disable-gdbmi \
+               --without-uiout \
                --disable-tui --disable-gdbtk --without-x \
                --without-included-gettext \
                --enable-threads \
        );
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-       strip $(PKG_BUILD_DIR)/gdb/gdb
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+       mkdir -p $(TOOLCHAIN_DIR)/usr/bin
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/gdb $(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb
+       ln -fs $(TARGET_CROSS)gdb $(TOOLCHAIN_DIR)/usr/bin/$(GNU_TARGET_NAME)-gdb
+       strip $(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb
 endef
 
-define Build/Install
-       install -c $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb
-       cd $(STAGING_DIR)/bin && \
-               ln -fs $(TARGET_CROSS)gdb $(GNU_TARGET_NAME)-gdb
+define Host/Clean
+       rm -rf \
+               $(HOST_BUILD_DIR) \
+               $(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb \
+               $(TOOLCHAIN_DIR)/usr/bin/$(GNU_TARGET_NAME)-gdb
 endef
 
 $(eval $(call HostBuild))