[backfire] backport r27648
[openwrt-10.03/.git] / toolchain / gdb / Makefile
index 4911faef1c844b5c9ef90c6e9c2d0888c55ffd7f..df4fe55a4a86091716cede3e93febb65f1d138d5 100644 (file)
@@ -7,17 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=6.3
+PKG_VERSION:=6.8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=05b928f41fa5b482e49ca2c24762a0ae
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/gdb
-PKG_CAT:=bzcat
+PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
+PKG_SOURCE_URL:=@GNU/gdb
 
-STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
-BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
-
-include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/toolchain-build.mk
 
 define Host/Configure
        (cd $(HOST_BUILD_DIR); \
@@ -28,8 +24,9 @@ define Host/Configure
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
+               --disable-werror \
                $(DISABLE_NLS) \
-               --without-uiout --disable-gdbmi \
+               --without-uiout \
                --disable-tui --disable-gdbtk --without-x \
                --without-included-gettext \
                --enable-threads \