fix GCC version.
[openwrt-10.03/.git] / toolchain / gcc / Makefile
index dc7e02c7ae8b80c94338819466dbbdaac2047c8a..7c037edddc0673b4458e902c82bf500b74019c22 100644 (file)
@@ -20,7 +20,7 @@
 
 include $(TOPDIR)/rules.mk
 
-GCC_VERSION:=$(strip $(GCC_VERSION))
+GCC_VERSION:=$(strip $(CONFIG_GCC_VERSION))
 
 #GCC_SITE:=ftp://ftp.gnu.org/gnu/gcc/releases/gcc-$(GCC_VERSION)
 GCC_SITE:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(GCC_VERSION) \
@@ -37,10 +37,10 @@ GCC_STRIP_HOST_BINARIES:=true
 #
 #############################################################
 
-ifeq ($(BR2_INSTALL_LIBGCJ),y)
+ifeq ($(CONFIG_INSTALL_LIBGCJ),y)
 TARGET_LANGUAGES:=c,c++,java
 else
-ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ifeq ($(CONFIG_INSTALL_LIBSTDCPP),y)
 TARGET_LANGUAGES:=c,c++
 else
 TARGET_LANGUAGES:=c
@@ -71,7 +71,7 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
        # We can dispense with the custom spec files, as well as libfloat for the arm case.
        # However, we still need a patch for arm.  There's a similar patch for gcc 3.3.x
        # which needs to be integrated so we can kill of libfloat for good.
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
 ifeq ("$(strip $(ARCH))","arm")
        $(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
 endif
@@ -79,6 +79,8 @@ ifeq ("$(strip $(ARCH))","armeb")
        $(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
 endif
 endif
+       $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(GCC_DIR)/gcc/version.c
+       $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(GCC_DIR)/gcc/version.c
        touch $(GCC_DIR)/.patched
 
 # The --without-headers option stopped working with gcc 3.0 and has never been
@@ -173,7 +175,7 @@ gcc-install: $(GCC_BUILD_DIR2)/.compiled
        #
        # Now for the ugly 3.3.x soft float hack...
        #
-ifeq ($(BR2_SOFT_FLOAT),y)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
 ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
        # Make sure we have a soft float specs file for this arch
        if [ ! -f ./$(GCC_VERSION)/specs-$(ARCH)-soft-float ] ; then \
@@ -185,9 +187,15 @@ ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
                echo staging dir specs file is missing ; \
                /bin/false ; \
        fi;
-       cp ./$(GCC_VERSION)/specs-$(ARCH)-soft-float $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
+       $(CP) ./$(GCC_VERSION)/specs-$(ARCH)-soft-float $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
 endif
 endif
+# We do another ugly hack here because the standard behaviour is
+# to include a reference to libgcc.so.1 in all binaries. For flash space
+# saving, we change the specs file to link in a static libgcc here. 
+       if [ -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
+               patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \
+       fi;
 
 source: $(DL_DIR)/$(GCC_SOURCE)
 prepare: $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc