demistifying make *clean targets, fix some clean targets issues
[openwrt-10.03/.git] / toolchain / binutils / binutils.mk
index afbb63ac3e2f155dff0d7f762d6f4e655451c9eb..3097a4bf211be93beda792f2caa0e8e015bcd6a3 100644 (file)
@@ -3,7 +3,7 @@
 # build binutils for use on the host system
 #
 #############################################################
-BINUTILS_VERSION:=$(strip $(BINUTILS_VERSION))
+BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
 
 BINUTILS_SITE:=http://ftp.kernel.org/pub/linux/devel/binutils
 ifeq ($(BINUTILS_VERSION),2.15)
@@ -79,7 +79,7 @@ binutils-clean:
        rm -f $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)*
        -$(MAKE) -C $(BINUTILS_DIR1) clean
 
-binutils-dirclean:
+binutils-toolclean:
        rm -rf $(BINUTILS_DIR1)
 
 
@@ -130,5 +130,5 @@ binutils_target-clean:
        rm -f $(TARGET_DIR)/bin/$(REAL_GNU_TARGET_NAME)*
        -$(MAKE) -C $(BINUTILS_DIR2) clean
 
-binutils_target-dirclean:
+binutils_target-toolclean:
        rm -rf $(BINUTILS_DIR2)