disable autorebuild for the toolchain, as it can easily lead to build breakages
[openwrt-10.03/.git] / toolchain / binutils / Makefile
index 2bbb48727b438a62f64dbc7962c9572190538d3b..2a881f83d4c7b9e005959b20dca912b4218511c7 100644 (file)
@@ -1,9 +1,53 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-include ./binutils.mk
+PKG_NAME:=binutils
+PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
 
-source: binutils-source
-prepare: $(BINUTILS_DIR)/.patched
-compile: $(BINUTILS_DIR1)/binutils/objdump
-install: binutils
-clean: binutils-distclean binutils-toolclean
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
+       ftp://gatekeeper.dec.com/pub/GNU/ \
+        ftp://ftp.uu.net/archive/systems/gnu/ \
+        ftp://ftp.eu.uu.net/pub/gnu/ \
+        ftp://ftp.funet.fi/pub/gnu/prep/ \
+        ftp://ftp.leo.org/pub/comp/os/unix/gnu/ 
+
+PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+PATCH_DIR:=./patches/$(PKG_VERSION)
+STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
+BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+override CONFIG_AUTOREBUILD=
+
+include $(INCLUDE_DIR)/host-build.mk
+
+EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-uclibc)
+
+define Build/Configure
+       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/
+       (cd $(PKG_BUILD_DIR); \
+               ./configure \
+               --prefix=$(STAGING_DIR_HOST) \
+               --build=$(GNU_HOST_NAME) \
+               --host=$(GNU_HOST_NAME) \
+               --target=$(REAL_GNU_TARGET_NAME) \
+               --disable-werror \
+               --disable-nls \
+               $(EXTRA_TARGET) \
+               $(SOFT_FLOAT_CONFIG_OPTION) \
+               $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
+       );
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+endef
+
+define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+$(eval $(call HostBuild))