[backfire] backport r27648
[openwrt-10.03/.git] / toolchain / Makefile
index 456b731fb88d540d2ec57287b180394deb449f26..fa417879a73b3b3e5860e8ae7e3d00a964930f27 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 curdir:=toolchain
 
 # subdirectories to descend into
-$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),,kernel-headers binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
 $(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
 $(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
 
 # builddir dependencies
-$(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  $(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
   $(curdir)/gcc/prepare:=$(curdir)/binutils/install
   $(curdir)/kernel-headers/install:=$(curdir)/gcc/prepare
   $(curdir)/gcc/compile:=$(curdir)/$(LIBC)/prepare
@@ -46,6 +46,11 @@ ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   endif
 endif
 
+ifdef CONFIG_GCC_VERSION_LLVM
+  $(curdir)/builddirs += llvm
+  $(curdir)/gcc/prepare += $(curdir)/llvm/install
+endif
+
 ifneq ($(ARCH),)
   $(TOOLCHAIN_DIR)/info.mk: .config
        @for dir in $(TOOLCHAIN_DIR); do ( \