next round of build system cleanup - convert package/ to new structure
[openwrt-10.03/.git] / toolchain / Makefile
index e8ee24ff7ae1d62015687cab7969b86f44d65d84..b7a45047ae0270421207f8e14ab67ab841d16572 100644 (file)
@@ -6,7 +6,6 @@
 #
 # Main makefile for the toolchain
 #
-file:=${lastword ${MAKEFILE_LIST}}
 curdir:=toolchain
 
 # subdirectories to descend into
@@ -22,11 +21,11 @@ endif
 $(curdir)/gcc/install:=$(curdir)/uClibc/install
 
 # prerequisites for the individual targets
-$(curdir)/ := .config $(tools/stamp)
+$(curdir)/ := .config $(tools/stamp-install) prereq
 $(curdir)//prepare = $(STAGING_DIR)/include-host/.done
 $(curdir)//compile = $(1)/prepare
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),toolchain))
+$(eval $(call stampfile,$(curdir),toolchain,install))
 $(eval $(call subdir,$(curdir)))