next round of build system cleanup - convert package/ to new structure
[openwrt-10.03/.git] / toolchain / Makefile
index a8bf7d6068d83384c40420ad142501dc03d1eed9..b7a45047ae0270421207f8e14ab67ab841d16572 100644 (file)
@@ -1,53 +1,31 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the toolchain
 #
-include $(TOPDIR)/rules.mk
+curdir:=toolchain
 
-TARGETS-y:=kernel-headers
-TARGETS-$(CONFIG_GDB) += gdb
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  TARGETS-y+=binutils gcc uClibc
-endif
-
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.toolchain_installed
-
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP) 
-clean: $(TARGETS_CLEAN)
+# subdirectories to descend into
+$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc uClibc)
 
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
-  $(STAMP): $(TARGETS_INSTALL)
-endif
-
-uClibc-prepare: kernel-headers-prepare
+# builddir dependencies
+$(curdir)/uClibc/prepare:=$(curdir)/kernel-headers/prepare
 ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  binutils-prepare: uClibc-prepare
-  gcc-prepare: binutils-install
-  uClibc-compile: gcc-compile
+  $(curdir)/binutils/prepare:=$(curdir)/uClibc/prepare
+  $(curdir)/gcc/prepare:=$(curdir)/binutils/install
+  $(curdir)/uClibc/compile:=$(curdir)/gcc/compile
 endif
-gcc-install: uClibc-install
-
-$(STAMP):
-       mkdir -p $(shell dirname $@)
-       touch $@
-
-$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME):
-       @mkdir -p $@
-       @ln -sf ../lib $@/lib
+$(curdir)/gcc/install:=$(curdir)/uClibc/install
 
-$(TOOLCHAIN_BUILD_DIR):
-       @mkdir -p $@
+# prerequisites for the individual targets
+$(curdir)/ := .config $(tools/stamp-install) prereq
+$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
 
-$(eval $(call default_subtargets,$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) $(TOOLCHAIN_BUILD_DIR)))
+$(eval $(call stampfile,$(curdir),toolchain,install))
+$(eval $(call subdir,$(curdir)))