add some sanity checking
[openwrt-10.03/.git] / toolchain / Makefile
index cbc726ef013b90cbff93b921b44a0319336b80ba..4afcc439a37a5a905848b810ce98d548a8580c0f 100644 (file)
@@ -23,7 +23,8 @@ ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   $(curdir)/uClibc/install:=$(curdir)/gcc/install
 endif
 
   $(curdir)/uClibc/install:=$(curdir)/gcc/install
 endif
 
-$(TOOLCHAIN_DIR)/info.mk: .config
+ifneq ($(ARCH),)
+  $(TOOLCHAIN_DIR)/info.mk: .config
        @for dir in $(TOOLCHAIN_DIR); do ( \
                set -x; \
                mkdir -p "$$dir"; \
        @for dir in $(TOOLCHAIN_DIR); do ( \
                set -x; \
                mkdir -p "$$dir"; \
@@ -32,6 +33,7 @@ $(TOOLCHAIN_DIR)/info.mk: .config
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
        @touch $@
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
        @touch $@
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq