fix a few directories missed in [4176]'s source -> download
[openwrt-10.03/.git] / target / utils / Makefile
index c08bd1a55dcd1b49cf2623a8b26df4cb7a654ea6..c7b9a049804d7817730e3d54f738362b93cde6a2 100644 (file)
@@ -1,16 +1,23 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-TARGETS := addpattern trx motorola-bin
+TARGETS := addpattern trx motorola-bin dgfirmware
 
 UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
 
+download:
 prepare: $(UTILS_BUILD_DIR)
-compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS))
+compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS)) FORCE
        mkdir -p $(STAGING_DIR)/bin
-       cp -a $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
+       $(CP) $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
 install: compile
 package:
-clean:
+clean: FORCE
        rm -rf $(UTILS_BUILD_DIR)
        for f in $(TARGETS); do \
                rm -f $(STAGING_DIR)/bin/$$f ; \