fix a few directories missed in [4176]'s source -> download
[openwrt-10.03/.git] / target / utils / Makefile
index b4c1a21ee04bf3432d7786d9d2335e0111927819..c7b9a049804d7817730e3d54f738362b93cde6a2 100644 (file)
@@ -1,17 +1,27 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-TARGETS := addpattern trx motorola-bin
+TARGETS := addpattern trx motorola-bin dgfirmware
 
 UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
 
+download:
 prepare: $(UTILS_BUILD_DIR)
-compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS))
+compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS)) FORCE
        mkdir -p $(STAGING_DIR)/bin
-       cp -a $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
+       $(CP) $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
 install: compile
 package:
-clean:
+clean: FORCE
        rm -rf $(UTILS_BUILD_DIR)
+       for f in $(TARGETS); do \
+               rm -f $(STAGING_DIR)/bin/$$f ; \
+       done
 
 $(UTILS_BUILD_DIR):
        mkdir -p $(UTILS_BUILD_DIR)