Add hardware details for WRT54G v1.1
[openwrt-10.03/.git] / target / squashfs / squashfsroot.mk
index fce71643fdbed38346de47b77190f6cbb96968a7..d3a104a83f3e6f0ed8e4ed4f95cbb72c5fe04de5 100644 (file)
@@ -48,13 +48,7 @@ squashfsroot-clean:
 squashfsroot-dirclean:
        rm -rf $(SQUASHFS_DIR)
 
-openwrt-linux.trx.squashfs:
-       $(BUILD_DIR)/trx -o openwrt-linux.trx.squashfs $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).squashfs
-
-openwrt-gs-code.bin.squashfs: openwrt-linux.trx.squashfs
-       $(BUILD_DIR)/addpattern -2 -i  openwrt-linux.trx.squashfs -o openwrt-gs-code.bin.squashfs -g
-
-openwrt-g-code.bin.squashfs: openwrt-gs-code.bin.squashfs
-       sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.squashfs > openwrt-g-code.bin.squashfs
-
-openwrt-image-squashfs:        openwrt-g-code.bin.squashfs
+ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
+TARGETS+=squashfsroot openwrt-image
+ROOTFS=squashfs
+endif