nbd's makefile/menuconfig rewrite
[openwrt-10.03/.git] / target / squashfs-lzma / squashfslzmaroot.mk
index 1aa80e0029d1f32b3c7c9deafb73be2a2b33c3ef..ee7ede84b0b36fa222775333bf92c333cc2ae770 100644 (file)
@@ -36,27 +36,7 @@ squashfslzma-dirclean:
 #
 #############################################################
 
-squashfslzmaroot: squashfslzma
-       @rm -rf $(TARGET_DIR)/usr/man
-       @rm -rf $(TARGET_DIR)/usr/info
-       $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma \
-       $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
-
 squashfslzmaroot-source: squashfslzma-source
 
-squashfslzmaroot-clean:
-       -$(MAKE) -C $(SQUASHFSLZMA_DIR) clean
-
 squashfslzmaroot-dirclean:
        rm -rf $(SQUASHFSLZMA_DIR)
-
-ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS_LZMA)),y)
-TARGETS+=squashfslzmaroot openwrt-image
-ROOTFS=squashfslzma
-
-openwrt-image:  openwrt
-       @make openwrt-code.bin TAG=W54G \
-       EXTRAVERSION=$(EXTRAVERSION)-SQUASHFSLZMA
-       @make openwrt-code.bin TAG=W54S \
-       EXTRAVERSION=$(EXTRAVERSION)-SQUASHFSLZMA
-endif