[sdk] do not copy all the staging_dir/ directories, only the right toolchain and...
[openwrt-10.03/.git] / target / sdk / Makefile
index 2b9ceff6c3a95033122f05e54d09a6b5d932f64e..55c1e135b0bf8ddfee5a92f597f6dde7f7648d4f 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -26,7 +25,7 @@ all: compile
 $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
        $(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
-       $(TAR) -cf - -C $(TOPDIR) $(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") --exclude="staging_dir/$(ARCH)" staging_dir | \
+       $(TAR) -cf - -C $(TOPDIR) $(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") --exclude="staging_dir/$(ARCH)" staging_dir/host staging_dir/target-$(ARCH)_$(LIBC)-$(LIBCV) staging_dir/toolchain-$(ARCH)_gcc-$(GCCV)_$(LIBC)-$(LIBCV) | \
                $(TAR) -xf - -C $(SDK_BUILD_DIR)
        mkdir -p $(SDK_BUILD_DIR)/target/linux
        $(CP) $(GENERIC_PLATFORM_DIR) $(PLATFORM_DIR) $(SDK_BUILD_DIR)/target/linux/