fix x86 image build order (fixes #3317)
[openwrt-10.03/.git] / target / linux / x86 / image / Makefile
index f19e6b3f38703d899f8ab65295829030a735922c..6649670df6f8fd3606d379062d4b17b3335a5834 100644 (file)
@@ -14,14 +14,6 @@ ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
 
 
 ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
-  define Build/Compile
-       $(MAKE) -C grub compile
-  endef
-
-  define Build/Clean
-       $(MAKE) -C grub clean
-  endef
-
   define Image/cmdline/squashfs
     block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
   endef
@@ -48,8 +40,8 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
        sed \
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
                -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
-               ./grub/menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
+       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
        $(call Image/Build/grub/$(1))
   endef
 endif
@@ -65,8 +57,19 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
   endef
 endif
 
+ifeq ($(CONFIG_X86_VDI_IMAGES),y)
+  define Image/Build/vdi
+    # left here because the image builder doesnt need these
+    ifeq ($(1),ext2)
+               rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi || true
+               vditool DD $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi $(BIN_DIR)/openwrt-$(BOARD)-ext2.image
+    endif
+  endef
+endif
+
+
 define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
+       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
        $(call Image/Prepare/grub)
 endef
   
@@ -74,15 +77,37 @@ define Image/Build/squashfs
     $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
 
+define Image/Build/iso 
+       $(CP) \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage2_eltorito \
+               $(KDIR)/root.grub/boot/grub/stage2_eltorito 
+       sed -i \
+               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
+               -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
+               -e 's#(hd0,0)#(cd)#g' \
+                $(KDIR)/root.grub/boot/grub/menu.lst 
+       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz 
+       mkisofs -R -b boot/grub/stage2_eltorito -no-emul-boot -boot-load-size 4 -boot-info-table \
+               -o $(KDIR)/root.iso $(KDIR)/root.grub 
+endef 
+
 define Image/BuildKernel
-       $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+       $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
 endef
 
 define Image/Build
        $(call Image/Build/$(1))
        $(call Image/Build/grub,$(1))
-       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
-       $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+       $(call Image/Build/vdi,$(1))
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
+       $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
 endef
 
 $(eval $(call BuildImage))
+
+ifeq ($(CONFIG_X86_VDI_IMAGES),y)
+  $(eval $(call RequireCommand,vditool, \
+       You need vditool to generate VirtualBox images. \
+  ))
+endif
+