added generation of x86 livecds, from #2391
[openwrt-10.03/.git] / target / linux / x86 / Makefile
index 705cc84ad1e4938b07da69413817972a0755b1b0..ddb50e64046b894ee4b2e1acf05bad5eaf5f2d5f 100644 (file)
@@ -13,11 +13,12 @@ FEATURES:=squashfs jffs2 ext2
 
 LINUX_VERSION:=2.6.22.4
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
-
+$(eval $(call Target,generic))
+$(eval $(call Target,mediacenter))
+$(eval $(call BuildTarget))
+$(eval $(call RequireCommand,mkisofs, \
+       Please install mkisofs. \
+))