add kernel_oldconfig target
[openwrt-10.03/.git] / target / linux / uml-2.6 / Makefile
index 33bf8060fef7806235de104d10c87642ce34079b..65e1b52f70f7b4a755ee20c8ae4b820d4a1049c8 100644 (file)
@@ -5,10 +5,31 @@
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host.mk
 
-ARCH:=i386
+# UML only makes sense on linux
+ifeq ($(HOST_OS),Linux)
+
+ARCH:=$(shell uname -m | sed \
+       -e 's/i[3-9]86/i386/' \
+       -e 's/mipsel/mips/' \
+       -e 's/mipseb/mips/' \
+       -e 's/powerpc/ppc/' \
+       -e 's/sh[234]/sh/' \
+       -e 's/armeb/arm/' \
+)
 BOARD:=uml
 BOARDNAME:=User Mode Linux
+FEATURES:=broken
+LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
+
+LINUX_VERSION:=2.6.21.5
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+endif
+
 $(eval $(call BuildKernel))