cleanup/rewrite of the kernel build process
[openwrt-10.03/.git] / target / linux / uml-2.6 / Makefile
old mode 100755 (executable)
new mode 100644 (file)
index 59f02b3..323eb2c
@@ -10,12 +10,5 @@ LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/kernel-build.mk
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+$(eval $(call BuildKernel))