use squashfs on the gemini by default, remove broken flag
[openwrt-10.03/.git] / target / linux / storm / Makefile
index c0d0023cc1e4582ba551b0b732c1fd546f595d95..9c5f4adcf315e5ab8dd868a6b3f8b2ea4d06b877 100644 (file)
@@ -10,8 +10,9 @@ ARCH:=arm
 BOARD:=storm
 BOARDNAME:=Storm SL3512
 FEATURES:=squashfs pci broken
+CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -19,10 +20,4 @@ define Target/Description
        Build images for boards based on the Storm Semiconductor SL3512, eg. Wiligear WBD-111
 endef
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
 $(eval $(call BuildTarget))