[backfire] rdc selects bridge, stp, llc and 8021q modules by default
[openwrt-10.03/.git] / target / linux / rdc / Makefile
index 185b67a214aca62e549908b1a5b74e43aa0df8d4..7f8bd260b0559b9dbf5655c1a5142b474886540f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
+FEATURES:=squashfs jffs2 pci usb pcmcia
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
 
-LINUX_VERSION:=2.6.28.10
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-rdc321x-wdt
+DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \
+                   wpad-mini kmod-r6040 kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
         Build firmware images for RDC321x based routers