split out profile definitions from Makefiles
[openwrt-10.03/.git] / target / linux / rdc-2.6 / Makefile
index e38565931291292fbc14469d9a1216ce65830c68..306734b273355a2058635e41d91cf98b90c5a586 100644 (file)
@@ -16,16 +16,9 @@ define Target/Description
         (e.g. Airlink101 AR525W)
 endef
 
-LINUX_VERSION:=2.6.19
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Ralink
-  NAME:=Ralink WiFi (default)
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))