split out profile definitions from Makefiles
[openwrt-10.03/.git] / target / linux / rdc-2.6 / Makefile
index 3fbd700c347539014e34e3f823c8fc243e194152..306734b273355a2058635e41d91cf98b90c5a586 100644 (file)
@@ -16,16 +16,9 @@ define Target/Description
         (e.g. Airlink101 AR525W)
 endef
 
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Ralink
-  NAME:=Ralink WiFi (default)
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))