cleanup/rewrite of the kernel build process
[openwrt-10.03/.git] / target / linux / rb532-2.6 / Makefile
index 23ecfe32b0c765213a47dd9c70bfc7f8f2b4a5ff..323eb2c3f4103b8cfc2e6af7356d1db94a166084 100644 (file)
@@ -1,18 +1,14 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.16.19
+LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=b1e3c65992b0049fdbee825eb2a856af
-
-include ../rules.mk
-include ./config
-
-include ../generic-$(KERNEL)/modules.mk
-include ../kernel.mk
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
+include $(INCLUDE_DIR)/kernel-build.mk
+$(eval $(call BuildKernel))