backfire: ppc40x: move perwe fixup into a separate function (backport of r20929)
[openwrt-10.03/.git] / target / linux / ppc40x / patches / 004-magicbox.patch
index d6ce22d4a89a6db77a3364c98a3d52b2657cc665..8de4a11b575fbf3b7765e4fbea75675f595ca40d 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/powerpc/boot/cuboot-magicbox.c
-@@ -0,0 +1,90 @@
+@@ -0,0 +1,96 @@
 +/*
 + * Old U-boot compatibility for Magicbox boards
 + *
 +
 +static bd_t bd;
 +
-+static void fixup_cf_card(void)
++static void fixup_perwe(void)
 +{
 +#define DCRN_CPC0_PCI_BASE    0xf9
-+#define CF_CS0_BASE   0xff100000
-+#define CF_CS1_BASE   0xff200000
 +
-+      /* Turn on PerWE instead of PCIsomething */
++      /* Turn on PerWE instead of PCIINT */
 +      mtdcr(DCRN_CPC0_PCI_BASE,
 +            mfdcr(DCRN_CPC0_PCI_BASE) | (0x80000000L >> 27));
 +
++#undef DCRN_CPC0_PCI_BASE
++}
++
++static void fixup_cf_card(void)
++{
++#define CF_CS0_BASE   0xff100000
++#define CF_CS1_BASE   0xff200000
++
 +      /* PerCS1 (CF's CS0): base 0xff100000, 16-bit, rw */
 +      mtdcr(DCRN_EBC0_CFGADDR, EBC_B1CR);
 +      mtdcr(DCRN_EBC0_CFGDATA, CF_CS0_BASE | EBC_BXCR_BU_RW | EBC_BXCR_BW_16);
@@ -48,7 +54,6 @@
 +      mtdcr(DCRN_EBC0_CFGADDR, EBC_B2AP);
 +      mtdcr(DCRN_EBC0_CFGDATA, 0x080bd800);
 +
-+#undef DCRN_CPC0_PCI_BASE
 +#undef CF_CS0_BASE
 +#undef CF_CS1_BASE
 +}
@@ -76,6 +81,7 @@
 +              devp = finddevice("/plb/ebc/cf_card@ff100000");
 +              del_node(devp);
 +      } else {
++              fixup_perwe();
 +              fixup_cf_card();
 +      }
 +
@@ -93,7 +99,7 @@
 +}
 --- /dev/null
 +++ b/arch/powerpc/boot/dts/magicbox.dts
-@@ -0,0 +1,281 @@
+@@ -0,0 +1,285 @@
 +/*
 + * Device Tree Source for Magicbox boards
 + *
 +                              reg = <0x00000000 0xffc00000 0x00400000>;
 +                              #address-cells = <1>;
 +                              #size-cells = <1>;
-+                              partition@0 {
++                              partition0@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x120000>;
++                                      reg = <0x0 0x140000>;
 +                              };
-+                              partition@120000 {
++                              partition1@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x120000 0x2a0000>;
++                                      reg = <0x140000 0x680000>;
 +                              };
-+                              partition@3c0000 {
++                              partition2@7c0000 {
 +                                      label = "u-boot";
-+                                      reg = <0x3c0000 0x30000>;
++                                      reg = <0x7c0000 0x30000>;
 +                                      read-only;
 +                              };
++                              partition3@0 {
++                                      label = "firmware";
++                                      reg = <0x0 0x7c0000>;
++                              };
 +                      };
 +              };
 +
 +};
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -42,6 +42,7 @@ $(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
+@@ -43,6 +43,7 @@ $(obj)/cuboot-hotfoot.o: BOOTCFLAGS += -
  $(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
  $(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
  $(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
  $(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
  $(obj)/virtex405-head.o: BOOTAFLAGS += -mcpu=405
  
-@@ -75,7 +76,7 @@ src-plat := of.c cuboot-52xx.c cuboot-82
+@@ -76,7 +77,8 @@ src-plat := of.c cuboot-52xx.c cuboot-82
                cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
                cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
                virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
--              cuboot-acadia.c cuboot-amigaone.c
-+              cuboot-acadia.c cuboot-amigaone.c cuboot-magicbox.c
+-              cuboot-acadia.c cuboot-amigaone.c cuboot-kilauea.c
++              cuboot-acadia.c cuboot-amigaone.c cuboot-kilauea.c \
++              cuboot-magicbox.c
  src-boot := $(src-wlib) $(src-plat) empty.c
  
  src-boot := $(addprefix $(obj)/, $(src-boot))
-@@ -192,6 +193,7 @@ image-$(CONFIG_DEFAULT_UIMAGE)             += uImag
- image-$(CONFIG_EP405)                 += dtbImage.ep405
+@@ -194,6 +196,7 @@ image-$(CONFIG_EP405)                      += dtbImage.ep40
+ image-$(CONFIG_HOTFOOT)                       += cuImage.hotfoot
  image-$(CONFIG_WALNUT)                        += treeImage.walnut
  image-$(CONFIG_ACADIA)                        += cuImage.acadia
 +image-$(CONFIG_MAGICBOX)              += cuImage.magicbox
  image-$(CONFIG_EBONY)                 += treeImage.ebony cuImage.ebony
 --- a/arch/powerpc/platforms/40x/Kconfig
 +++ b/arch/powerpc/platforms/40x/Kconfig
-@@ -50,6 +50,16 @@ config KILAUEA
+@@ -60,6 +60,16 @@ config KILAUEA
        help
          This option enables support for the AMCC PPC405EX evaluation board.
  
        depends on 40x
 --- a/arch/powerpc/platforms/40x/ppc40x_simple.c
 +++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
-@@ -54,7 +54,8 @@ static char *board[] __initdata = {
-       "amcc,acadia",
+@@ -55,7 +55,8 @@ static char *board[] __initdata = {
        "amcc,haleakala",
        "amcc,kilauea",
--      "amcc,makalu"
-+      "amcc,makalu",
+       "amcc,makalu",
+-      "est,hotfoot"
++      "est,hotfoot",
 +      "magicbox"
  };