add preliminary MPC83xx support
[openwrt-10.03/.git] / target / linux / mpc83xx / Makefile
diff --git a/target/linux/mpc83xx/Makefile b/target/linux/mpc83xx/Makefile
new file mode 100644 (file)
index 0000000..4dca616
--- /dev/null
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2007-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=mpc83xx
+BOARDNAME:=Freescale MPC83xx
+FEATURES:=tgz broken
+
+LINUX_VERSION:=2.6.30.9
+LINUX_KARCH:=powerpc
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-via-velocity
+
+define Target/Description
+       Build firmware images for Freescale MPC83xx based boards (eg. RouterBoard 600).
+endef
+
+$(eval $(call BuildTarget))