[mpc52xx] add new target for Freescale MPC52xx based boards
[openwrt-10.03/.git] / target / linux / mpc52xx / Makefile
diff --git a/target/linux/mpc52xx/Makefile b/target/linux/mpc52xx/Makefile
new file mode 100644 (file)
index 0000000..f36c883
--- /dev/null
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=mpc52xx
+BOARDNAME:=Freescale MPC52xx
+FEATURES:=tgz ext2
+
+LINUX_VERSION:=2.6.30.3
+LINUX_KARCH:=powerpc
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+       Build images for the Freescale MPC52xx based boards.
+endef
+
+$(eval $(call BuildTarget))