[magicbox] fix compile error
[openwrt-10.03/.git] / target / linux / magicbox / patches / 100-cf_slot.patch
index 3a5dde7709b5e9af4d05fad5b620c9fb450ebb71..79f567216f2f3a50a2a87cbb0ee4e052b5dabef5 100644 (file)
@@ -1,30 +1,29 @@
-Index: linux-2.6.22-rc6/drivers/ide/ide.c
-===================================================================
---- linux-2.6.22-rc6.orig/drivers/ide/ide.c    2007-06-28 08:23:49.463514496 +0200
-+++ linux-2.6.22-rc6/drivers/ide/ide.c 2007-06-28 08:23:54.658724704 +0200
-@@ -1604,6 +1604,7 @@
- extern void __init pnpide_init(void);
- extern void __exit pnpide_exit(void);
- extern void __init h8300_ide_init(void);
+--- a/drivers/ide/ide.c
++++ b/drivers/ide/ide.c
+@@ -78,6 +78,10 @@
+ /* default maximum number of failures */
+ #define IDE_DEFAULT_MAX_FAILURES      1
++#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
 +extern void __init ide_magicbox_init(void);
++#endif
++
+ struct class *ide_port_class;
+ static const u8 ide_hwif_to_major[] = { IDE0_MAJOR, IDE1_MAJOR,
+@@ -494,6 +498,9 @@
  
- /*
-  * probe_for_hwifs() finds/initializes "known" IDE interfaces
-@@ -1668,6 +1669,9 @@
- #ifdef CONFIG_H8300
-       h8300_ide_init();
+       return -EPERM;
  #endif
 +#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
 +      ide_magicbox_init();
 +#endif
  }
  
- /*
-Index: linux-2.6.22-rc6/drivers/ide/Kconfig
-===================================================================
---- linux-2.6.22-rc6.orig/drivers/ide/Kconfig  2007-06-28 08:23:49.470513432 +0200
-+++ linux-2.6.22-rc6/drivers/ide/Kconfig       2007-06-28 08:23:54.658724704 +0200
-@@ -946,6 +946,14 @@
+ int set_pio_mode(ide_drive_t *drive, int arg)
+--- a/drivers/ide/Kconfig
++++ b/drivers/ide/Kconfig
+@@ -928,6 +928,14 @@
  
          If unsure, say N.
  
@@ -39,15 +38,10 @@ Index: linux-2.6.22-rc6/drivers/ide/Kconfig
  choice
        prompt "Type of MPC8xx IDE interface"
        depends on BLK_DEV_MPC8xx_IDE
-Index: linux-2.6.22-rc6/drivers/ide/Makefile
-===================================================================
---- linux-2.6.22-rc6.orig/drivers/ide/Makefile 2007-06-28 08:23:49.478512216 +0200
-+++ linux-2.6.22-rc6/drivers/ide/Makefile      2007-06-28 08:23:54.659724552 +0200
-@@ -37,6 +37,7 @@
- # built-in only drivers from ppc/
- ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
- ide-core-$(CONFIG_BLK_DEV_IDE_PMAC)   += ppc/pmac.o
-+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE)       += ppc/magicbox_ide.o
+--- a/drivers/ide/ppc/Makefile
++++ b/drivers/ide/ppc/Makefile
+@@ -1,3 +1,4 @@
  
- # built-in only drivers from h8300/
- ide-core-$(CONFIG_H8300)              += h8300/ide-h8300.o
+ obj-$(CONFIG_BLK_DEV_IDE_PMAC)                += pmac.o
+ obj-$(CONFIG_BLK_DEV_MPC8xx_IDE)      += mpc8xx.o
++obj-$(CONFIG_BLK_DEV_MAGICBOX_IDE)    += magicbox_ide.o