strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt-10.03/.git] / target / linux / magicbox / Makefile
diff --git a/target/linux/magicbox/Makefile b/target/linux/magicbox/Makefile
new file mode 100644 (file)
index 0000000..e003330
--- /dev/null
@@ -0,0 +1,21 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=magicbox
+BOARDNAME:=Magicbox
+FEATURES:=squashfs jffs2
+
+LINUX_VERSION:=2.6.22.4
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))